• Автор:

    Flesha
  • Добавлено:

    янв 30, 2016
  • Комментариев:

    1
  • Просмотров:

    740

phpBBex 2.0.2 Rus

phpBBex 2.0.2 Rus

phpBBex 2.0.2 Rus (phpBB extended) — это новый и набирающий популярность форк phpBB 3, в который уже встроены наиболее востребованные возможности и даже больше. Большинство нововведений уникально и не существует в виде модов, а тот код, что был взят из существующих модификаций, был сильно переработан: исправлены ошибки, код оптимизирован и адаптирован под последние версии phpBB. При этом новые возможности совершенно не навязываются — этому способствует большое количество новых опций в панели администратора, где всё лишнее вы можете просто отключить.

Важно заметить, что phpBBex — это форк phpBB со своим независимым циклом разработки. Это означает, что phpBBex — это не сборка, в которых как правило просто предустановлено несколько модов. Цель ответвления заключается в создании максимально гибкого движка форумов без превращения его в комбайн на все случаи жизни. Это означает, что в стандартной поставке никогда не появится галерей, блогов и других вещей, напрямую не относящихся к форумам.

Проект начат 16 февраля 2011 года. В основу легли наработки 2008-2010 годов, которые изначально были созданы для форума города Слуцка. Первая стабильная версия phpBBex была анонсирована 9 октября 2011 года. С каждым релизом в phpBBex появляются новые возможности и опции, которые невозможно не заметить. Анонсы новых версий phpBBex достаточно красноречивы: 1.1, 1.2, 1.3, 1.4, 1.5, 1.6 и 1.7.

Что характерно, phpBBex быстро перенимает все обновления из основной ветки phpBB. Разработка была начата на базе phpBB 3.0.8, и переход phpBBex на новую версию базового кода осуществлялся в среднем за день-два после очередного релиза phpBB. Например, phpBBex 1.7.0 был приурочен к выходу phpBB 3.0.12, при этом кроме обновления базового кода в новом релизе нашлось место и массе других приятных мелочей.

Разработка phpBBex ведётся на профессиональном уровне. Исходные коды находятся под контролем системы управления версиями Mercurial. Все самые последние новшества, которые ещё не вошли в очередной релиз, вы всегда сможете найти репозитории проекта. Все изменения тестируются сразу же на нескольких форумах, поэтому свежайшая ревизия обычно достаточно стабильна. Однако, недостаточно опытным пользователям всё же рекомендуется использовать последнюю релизную версию.

Из-за значительного количества изменений серьёзные моды для phpBB перед установкой на phpBBex скорее всего придётся обрабатывать напильником, а пакеты локализации и стили от phpBB и вовсе не заработают без соответствующей переработки. Однако, вокруг phpBBex уже собралось небольшое сообщество, которое помогает развитию проекта: KDit выпустил пакет локализации phpBBex на украинский язык; Bricklayer и KDit выпустили адаптацию некоторых тяжёлых модов от phpBB для phpBBex. Вы также при желании можете присоединиться.

Если в phpBBex есть возможности, которых вам не хватает в стандартном phpBB 3 — без сомнений, phpBBex будет для вас верным выбором. Если вы сомневаетесь, ознакомьтесь ниже с возможностями phpBBex и сравните преимущества и недостатки выбора phpBBex или phpBB.

Вышел phpBBex 2.0.2, основанный на phpBB 3.1.7pl1
Не вышел phpBB 3.1.7, а за ним вышел phpBB 3.1.7pl1 smile
Как всегда добавлены новые события и исправлены ошибки.
Множество ошибок было исправлено в STK, спасибо пользователю Sheer за его поддержку.
А главной особенностью этого релиза является поддержка движком форума PHP седьмой версии, что позволяет генерировать страницы быстрее на 180%, потребляя на 50% меньше памяти smile
К сожалению, не все расширения могут быть совместимы с новой версией, поэтому рекомендуется обновить их до последних версий. Если это не поможет, обращайтесь на форум поддержки, исправим wink
Так же в этом релизе уже исправлены ошибки оригинального phpBB 3.1.7pl1, кроме особенности с задержкой отображения самого себя в "Кто сейчас на форуме", что, впрочем, никак не влияет на статистику или другие функции.

Требования:
PHP не ниже 5.3.3 с поддержкой Unicode в регулярных выражениях, поддерживается PHP 7.0 и выше
MySQL не ниже 3.23 или любая другая совместимая БД, например, MariaDB 5.1

Вернуться

Комментарии:


  1. Amney → 2 марта 2016 10:52
    Хороший форк.Давно пользуюсь.Еще с не обновляемых уже версий.
Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.